Cube Long Arrow Right External Link angle-right Search Times Spinner angle-left

A - Plugins Compatible With Mojave?

Curious if our plugins are Mac OS Mojave ready?

We can guarantee that all of our plugins are compatible with Mac OS 10.14 Mojave.

If you find that any of your installed plugins lose functionality after updating please follow these steps:

1) Check to see if you still have the download folder containing the installer for the plugin again. If you do, close Final Cut and run the installer once more.

2) If you do not still have the download folder or if your download folder is more than a year old, please download the plugin once more from your purchase history on our website.

If after following the steps above you find that your plugin is still no longer working properly, please reach out to Pixel Support with the name of the plugin and a screenshot of the error as it occurs.